Nuovo utilizzatore PCLinuxOS - domanda aggiornamenti

Ritratto di filips

Buonasera, mi sono appena iscritto e ho da pochissimo installato questo SO (LXDE). Avendo avuto esperienza solo con Ubuntu e derivate, mi sembra di notare che ora le cose siano leggermente diverse, l'utente 'sudo' non esiste, per esempio, nell'LXTerminal in dotazione col SO non compare il manuale di un sacco di comandi (tra cui appunto il 'sudo'). Domanda: qui per le operazioni di rango più elevato, si usa solo il root? Ora vorrei anche eseguire l'update e l'upgrade del sistema, ma seguendo informazioni reperite in rete (http://www.lffl.org/2014/09/primi-passi-con-pclinuxos.html), la cosa non mi risulta fattibile. Se guardate il link, noterete che viene indicato lo stesso modello utilizzato in Ubuntu, ma come ho detto, le cose non sembrano confermate: "bash: sudo: command not found". Eppure la pagina del link sembra aggiornata. Forse occorre un'altra shell, la Bash?

Ritratto di adrianomorselli

su + tua_password_di_root (enter) apt-get update apt-get dist-upgrade. Ma la procedura corretta è aprire synaptic, cliccare su aggiorna, selezionare tutti gli aggiornamenti, applica. Qui il manuale che non è certo lffl.org, lascialo stare se non vuoi incorrere in guai, http://pclinuxoshelp.com/index.php/Update_Your_PCLinuxOS

Ritratto di dxgiusti

ed avevo anche scritto agli amici di lffl ma indubbiamente sono troppo impegnati a pubblicare tutto di tutti, peccato che non verifichino quanto scrivono. anche per ubuntu hanno causato divrsi guai....... l'ultimo con una forzatura sull'audio. meglio chiedere sui forum specifici che prendere per oro colato le loro info.

Ritratto di filips

Ringrazio per il manuale del sito ufficiale. Come consigliato, ho utilizzato Synaptic, e alla fine è apparsa l'avviso indicato anche alla pagina-istruzioni segnalata:

In case Synaptic gives a prompt such as 'Not able to retrieve all packages, continue anyway?' DO NOT click Yes. Say NO and try updating sometime later. This might be because the repositories are being updated with new software themselves and only after this process is complete, you should update your system. If the message continues to appear even after a day, report the issue to the forum

quindi attenderò per effettuare un ulteriore tentativo.

Allora in PCLOS si usa Synaptic (in Ubuntu l'ho usato poche volte visto che esiste il Software Center). Quindi se sono per es. interessato a un certo pacchetto faccio la ricerca e poi lascio gestire tutto a questo manager, ivi compresi gli aggiornamenti del sistema. Su questi ultimi devo ancora chiedere se è normale che la iso usata nell'installazione mi dia un PCLOS con un Firefox versione 34.0.5. E' normale che dopo l'upgrade, la versione sia ancora la 34? Guardate i dati salienti del SO:

LSB_VERSION=lsb-3.1-ia32:lsb-3.1-noarch
DISTRIB_ID=PCLinuxOS
DISTRIB_RELEASE=
DISTRIB_CODENAME=
DISTRIB_DESCRIPTION="PCLinixOS"
PCLinuxOS release 2014 (PCLinuxOS) for i586

e il kernel..

Linux 3.18.1-pclos1 i686

Tutto a posto?

Molto contento di questa distro, per l'agilità e reattività. Virtualizzata (su Kubuntu) si carica e risponde molto più rapidamente di Lubuntu (provata su Ubuntu), stessa macchina.

Ritratto di adrianomorselli

Verso che repositories punti? Apri synaptic, clicca su impostazioni/archivi dei pacchetti e controlla che il tuo punti su http://ftp.nluug.nl/pub/os/Linux/distr/pclinuxos/pclinuxos/apt/

Non, ripeto non utilizzare più di un repositories, se metti la spunta su di uno togli la spunta all'altro Wink Ricarica e vedrai che stavolta gli aggiornamenti vanno a buon fine e firefox andrà alla versione 42. Per il kernel utilizza questo finchè tutto funziona bene, cambialo solo quando avrai delle incompatibilità o malfunzionamenti. Ciao

Ritratto di tuxino

e ricorda che l'upgrade, come su ubuntu non va usato,
su -
apt-get update && apt-get dist-upgrade

Ritratto di filips

Ho risolto bene tutto. Grazie per i vostri consigli e per le integrazioni - in Settings c'era solo il repository che hai indicato. D'ora in poi farò esclusivamente riferimento al sito del progetto (l'avevo trovato inizialmente ma non avevo notato la guida) e a questo sito parente italiano. Un grazie a dxgiusti per la dritta PCLOS.

Ritratto di Hertz

Buongiorno filips,

filips wrote:
Buonasera, mi sono appena iscritto e ho da pochissimo installato questo SO (LXDE). Avendo avuto esperienza solo con Ubuntu e derivate, mi sembra di notare che ora le cose siano leggermente diverse, l'utente 'sudo' non esiste, per esempio, nell'LXTerminal in dotazione col SO non compare il manuale di un sacco di comandi (tra cui appunto il 'sudo'). Domanda: qui per le operazioni di rango più elevato, si usa solo il root? Ora vorrei anche eseguire l'update e l'upgrade del sistema, ma seguendo informazioni reperite in rete (http://www.lffl.org/2014/09/primi-passi-con-pclinuxos.html), la cosa non mi risulta fattibile. Se guardate il link, noterete che viene indicato lo stesso modello utilizzato in Ubuntu, ma come ho detto, le cose non sembrano confermate: "bash: sudo: command not found". Eppure la pagina del link sembra aggiornata. Forse occorre un'altra shell, la Bash?

Intervengo per collegarmi all'applicazione sudo che comunque anche se non è presente di default in PCLOS, è comunque reperibile sui repository ufficiali ed una volta installata nel sistema e opportunamente configurata, funziona perfettamente utilizzando i classici comandi da terminale o shell (apt-get install etc. etc.).

Per fare in modo che sudo funzioni (dopo aver installato il pacchetto), si deve aggiungere l'utente nel file presente in /etc/sudoers (loggandoti come root), alla riga sottostante la voce root (scorrendo il file in corrispondenza della voce relativa alle autorizzazioni), con un editor di testo (che nel tuo caso potrebbe essere leafpad), salvare e chiudere, per poi riavviare il terminale.

A questo punto sudo è configurato correttamente e può essere utilizzato come lo usavi in Ubuntu e derivate.

Ritratto di francesco bat

E pensare che tempo fa li contattai pure per quell'articolo e li avvisai che il comando "sudo" non era di default su pclinuxos ma bisogna usare "su".

Ma dopo più di 1 anno non hanno ancora modificato l'articolo Biggrin

Ciao

Francesco bat

Ritratto di filips

Grazie mille per questa ottima indicazione

Per il momento cmq lo mantengo come è così mi faccio un po' il callo a un Linux "come natura crea" (perche' se non ricordo male fra le cose che sto leggendo, il superuser non esisteva nelle versioni iniziali - e in parecchie attuali)

Ritratto di axa

Per quanto riguarda il blog di lffl ,adesso è fermo direi in stasi.
Saluti

Ritratto di gs181it

mi intrometto in questa discussione proprio perchè remore dei comandi su base debian sul terminale non riuscivo a capire come immettere la lingua italiana su de mate davo comandi classici da terminale ma le regional setting mi davano l,errore del sistema non aggiornato, ho riavviato il so, poi da buon niubbo come si dice in rete mi accorgo dell,icona in basso a dx che mi dava la notifica degli aggiornamenti apro synapstic e avvio procedura di aggiornamento, finito tutto provo a cambiare lingua e risolto il tutto, successivamente ho aggiornato il pacchetto libreoffice.

Ritratto di adrianomorselli

Pclinuxos ha un ottimo tool "configure your pclinuxos" che ti evita del tutto l'utilizzo del terminale per queste cose

Ritratto di filips

risolto