Menù di avvio

Ritratto di III

Salve a tutti
da stamane sono in crisi.
Ho provato ad installare sul secondo hd (sdb) win xp e non ci sono riuscito (accidenti a me).
Durante il tentativo ho provato a partizionare solo il secondo hd senza toccare il primo.
Quando ho provato a far ripartire Pclos, dal primo hd (sda), non mi da piu il menù grafico di avvio e di consguenza Pclos non si avvia. Ho provato anche a far ripartire il livecd, ma il primo hd (sda) non lo vede piu.
Ho combinato qualcosa di grave?
Si può ripristinare il mi so preferito o devo reinstallare tutto da capo?
Grazie

Ritratto di joanlui

devi sempre installare prima Windows e qualsiasi distribuzione di linux in subordine. mi sa che ti tocca formattare tutto e ripartire con l'installazione di Windows.

Ritratto di zafran

Cosa vuol dire che non vede sda? Se c'è lo deve vedere, magari non monta in automatico, ma il disco lo dovrebbe vedere anche se avessi spianato la tabella delle partizioni.

Con un livecd dovresti prima di tutto vedere cosa c'è in hda e hdb, se i due sistemi sono al loro posto un grub nel mbr lo rimetti anche con lo stesso livecd o meglio ancora con un RescueCd o SuperGrub che sono livecd con sistemi minimali fatti apposta per queste situazioni incasinate.

Ritratto di patel

da live cd vai sul terminale e dai il comando (l = elle)
fdisk -l
se ti dice che non hai i permessi fai
su
fdisk -l
e posta il risultato

Ritratto di III

Questo è il risultato del comando fdisk -l
Disk /dev/hdb: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 16253 8191480+ 83 Linux
/dev/hdb2 16254 158816 71851752 5 Extended
/dev/hdb3 * 1 1 0 0 Empty
Partition 3 does not end on cylinder boundary.
/dev/hdb4 * 1 1 0 0 Empty
Partition 4 does not end on cylinder boundary.
/dev/hdb5 16254 24379 4095472+ 82 Linux swap / Solaris
/dev/hdb6 24380 158816 67756216+ 83 Linux

PS: ho trovato un file chiamato grub menu.abw
e dentro cè questa riga:
kernel (hd1,0)/boot/vmlinuz BOOT_IMAGE=Pclinuxos root=/dev/hda1 splash=silent
initrd (hd1,0)/boot/initrd.img
mi può essere utile?
Grazie x l'aiuto

Ritratto di patel

In effetti fdisk mostra solo il disco da 80 Gb dove hai Linux, non è che hai provato a staccare l'altro disco e non l'hai riconnesso bene ? Probabilmente la fallita installazione di win ha cancellato il grub. Controlla se il bios te lo vede l'altro disco. Per rinstallare il grub da cd live, terminale dai i comandi:

grub
find /boot/grub/menu.lst (ti darà un risultato tipo (hd0,X) che tu copi nel comando root)
root (hd0,X)
setup (hd0)
quit

Ritratto di III

ok, ho dato il comando che mi hai suggerito da root:
grub> find /boot/grub/menu.lst
Error 15: File not found
Nel bios mi vede tutti e due gli hd

Ritratto di zafran

Mi sa che così non si va molto avanti.

# fdisk /dev/hda cosa ti dà?
# fdisk /dev/hdb cosa ti dà?
Se da live cd provi a montare (da shell) hda e hdb cosa risponde?

Può darsi che nel secondo hd ci fosse stato in precedenza un linux al cui /boot/grub/menu.1st facesse riferimento anche il linux di hda?

Può darsi che hda in realtà sia invece hdb?
A me è successo che linux mi desse gli hd invertiti rispetto al bios perché la disposizione sul cavo non rispettava la posizione dei jumper.

http://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino

Ritratto di III

Ecco i risultati di fdisk:
[root@localhost Desktop]# fdisk /dev/hda
Impossibile aprire /dev/hda
[root@localhost Desktop]# fdisk /dev/hdb
The number of cylinders for this disk is set to 158816.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
(e.g., DOS FDISK, OS/2 FDISK)

Misà che hai ragione mi ha invertito gli hd.
In effetti sul hd, hdb, è rimasto il partizionamento di Pclos
Adesso provo con SuperGrub e vi faccio sapere, sembra interessante...

Ritratto di zafran

Io credo che se fdisk non vede un disco non lo vedrà nemmeno SuperGrub.

Prima di tutto proverei a staccare fisicamente uno dei due sincerandomi di come è messo e con livecd guarderei cosa vede.
Poi farei lo stesso con l'altro evitando di scrivere nel mbr fino a che non fossi sicuro di cos'è successo.

Ritratto di xXxmrc

devi sempre installare per primo windows,perche non ti lascia altra opzione
sovvrascrive sempre il MBR lo ho sperimentato gia tanti anni fa!!!
installi prima windows (dove tu vuoi) e dopo linux il quale poi con grub o lilo
ti dara la tua bella schermata in cui poter fare il boot con windows o linux
ciao ...spero ti sia di aiuto

Ritratto di III

scusate, in questi gg nn ho potuto dedicarmi al ripristino del sistema.
Ho fatto vari tentativi da voi suggeriti( l'ultimo con il wiki di ubuntu), ma nn sono andati a buon fine, e quindi reinstallerò tutto da capo, mi servirà da lezione.
Anche con SG non ho risolto al casino che ho combinato.
I vostri suggerimenti hanno aggiunto sicuramente esperienza.
Grazie, sopratutto x la pazienza